Download
Free
 
Eclipse 3.1
3.0-2.1-2.0
 
Studio
 
Eclipse 3.2
3.1-3.0-2.1
 
EclipseUML Studio Edition for Eclipse since June 2004

On this page you can find our latest EclipseUML Studio release :

Two distributions are available for EclipseUML Studio Edition for Eclipse 3.1.2 :

  • An auto-installer jar file which contains EclipseUML Free Edition, EMF, GEF and UML2.
  • A Stand Alone Eclipse auto-installer jar file which contains Eclipse 3.1.2, EclipseUML Studio Edition, EMF, GEF and UML2 for windows 2000/XP (size 192 342 633 Bytes). To launch the jar file from windows: Open the Control Panel > Folder Option > File Types > select Jar > Change > Open with Java.

Previous EclipseUML installation should be uninstalled.


Eclipse 3

Eclipse 3.1 versions has been qualified for :

Eclipse 3.1 release of the EclipseUML Plugin is written and compiled against version 1.4.2 of the Java 2 Platform APIs, and targeted to run on version 1.4.x or 1.5.x of the Java 2 Runtime Environment, Standard Edition.

Eclipse 3.0.2 versions has been qualified for :

Eclipse 3 release of the EclipseUML Plugin is written and compiled against version 1.4.2 of the Java 2 Platform APIs, and targeted to run on version 1.4.1 or higher of the Java 2 Runtime Environment, Standard Edition.

One distribution is available :

Documentation

Auto-Installer

Eclipse 3.1.2 is required.

Bundled EMF (Eclipse Modeling Framework )

Bundled GEF (Graphical Editor Framework)

Bundled UML2

 
 
EclipseUML 2.1.0.20060411 04/11/2006 87 695 273 Bytes

Eclipse 3.1 is required.

Bundled EMF (Eclipse Modeling Framework )

Bundled GEF (Graphical Editor Framework)

Bundled UML2

 
 
EclipseUML 2.1.0.20050927 beta 09/27/2005 86 894 676 Bytes

Eclipse 3.0.2 is required.

Bundled EMF (Eclipse Modeling Framework )

Bundled GEF (Graphical Editor Framework)

Bundled UML2

 
 
EclipseUML 2.0.0.20050411 04/11/2005 48 370 536 Bytes

Eclipse 3.0.1 is required.

Bundled EMF (Eclipse Modeling Framework )

Bundled GEF (Graphical Editor Framework)

 
 
EclipseUML 2.0.0.20050228 beta 02/28/2005 48 355 574 Bytes
EclipseUML 2.0.0.20050222 beta 02/23/2005 48 041 983 Bytes
EclipseUML 1.1.0.20041125 11/29/2004 45 218 453 Bytes
EclipseUML 1.1.0.20041104 11/04/2004 45 227 280 Bytes

Eclipse 3.0 is required.

The EMF (Eclipse Modeling Framework ) plugin is bundled.

The GEF (Graphical Editor Framework) plugin is bundled.

 
 
EclipseUML 1.0.1.20040831 08/31/2004 39 695 701 Bytes

Eclipse 3.0 is required.

The EMF (Eclipse Modeling Framework ) plugin is bundled.

The GEF (Graphical Editor Framework) plugin is bundled.

 
 
EclipseUML 1.0.0.20040719 07/19/2004 38 511 746 Bytes

EclipseUML Studio for Eclipse 2.1.1

On this page you can find our latest EclipseUML Studio release :

Previous EclipseUML installation should be uninstalled.


Eclipse 2

Eclipse 2 versions has been qualified for :

These versions has been qualified for the following JDK :

One distribution is available :

Documentation

Auto-Installer

Eclipse 2.1.3 is required.

 
 
EclipseUML 1.0.0.20040614 06/14/2004 34 984 751 Bytes
 
 
 
 
 
Last update Wed July 12 17:55:55 CET 2006 Valid XHTML 1.0 Valid CSS All text, graphics © 2002-2006 by Omondo